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Troubleshooting ROBOTC with Cortex
This guide is to designed to be used by a student or teacher as a reference for help troubleshooting 
ROBOTC software issues.

Troubleshooting Topics
•	 Computer	will	not	Recognize	the	VEX	Cortex
•	 Not	able	to	Download	my	ROBOTC	program	over	USB
•	 Not	able	to	Download	ROBOTC	Firmware	over	USB
•	 Not	able	to	Download	Master	CPU	Firmware	over	USB
•	 Program	will	not	Compile
•	 Program	compiles,	but	does	not	behave	as	desired
•	 Not	able	to	open	the	ROBOTC	Debugger
•	 Motors	and/or	Sensors	Debug	windows	not	functioning	correctly
•	 Program	does	not	immediately	run	when	Cortex	is	turned	on

Problem: Computer will not Recognize the VEX Cortex
1.	Was	the	correct	startup	sequence	followed	when	connecting	the	Cortex	to	the	computer?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On

2.	Is	the	connected	battery	sufficiently	charged?
•	 Swap	in	a	fully	charged	battery

3.	Does	the	Cortex	need	to	be	power	cycled?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On

4.	Try	another	USB	port	on	the	computer.
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On

5.	Try	putting	the	Cortex	into	“Bootload”	mode
•	 Start	with	the	Cortex	turned	OFF	(but	with	a	battery	connected)
•	 Push	and	hold	Config	button	in	on	the	Cortex.
•	 Attach	the	USB	cable	between	the	PC	and	Cortex.
•	 Wait	for	the	Robot,	VEXnet	and	Game	lights	to	blink	green.
•	 Release	Config	button.
•	 Turn	the	Cortex	ON.
•	 Then	in	ROBOTC,	click	“Robot”,	“Download	Firmware”,	“Master	CPU	Firmware”,	“Standard	File”.
•	 After	the	Master	CPU	Firmware	finishes	downloading,	click	“Robot”,	“Download	Firmware”,	“ROBOTC	

Firmware”,	“Standard	File”.
Additional	Note:	This	step	may	be	necessary	if	the	Master	CPU	Firmware	was	corrupted	and/or	only	partially	
downloaded	to	the	Cortex.	Also	possible,	if	the	wrong	firmware	(VEXnet	Joystick)	was	downloaded	to	the	
Cortex,	this	step	may	be	necessary.
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Troubleshooting ROBOTC with Cortex

6.	Make	sure	that	your	computer	allows	for	“new	hardware”	to	be	connected.	Extremely	locked	down	
computers	may	prohibit	new	hardware	such	as	the	VEX	Cortex	from	being	connected.
•	 Contact	your	Tech	Support	for	additional	priviledges

7.	Some	SmartBoard	software	causes	a	conflict	with	the	Cortex.	The	SMART	Virtual	TabletPC	device	can	be	
disabled	to	resolve	the	conflict.
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Problem:  Not able to Download my ROBOTC program over USB
1.	Was	the	correct	startup	sequence	followed	when	connecting	the	Cortex	to	the	computer?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	program

2.	Does	the	program	compile?
•	 Fix	any	errors	(red	x’s)	
•	 Retry	downloading	the	program

3.	Is	the	correct	Platform	Type	Selected?
•	 Verify	that	the	correct	platform	type	is	selected	under	Robot	>	Platform	Type
•	 Retry	downloading	the	program

4.	Is	the	connected	battery	sufficiently	charged?
•	 Swap	in	a	fully	charged	battery
•	 Retry	downloading	the	program

5.	Does	the	Cortex	need	to	be	power	cycled?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	program

6.	Have	the	Master	CPU	and	ROBOTC	Firmware	been	downloaded	successfully	to	the	Cortex?	
•	 Do	they	need	to	be	re-downloaded?
o	 Download	the	Master	CPU	Firmware .........................
o	 Download	the	ROBOTC	Firmware
o	 Power	Cycle	the	Cortex
o	 Retry	downloading	the	program

7.	Try	another	USB	port	on	the	computer.
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	program

8. Restart ROBOTC.
•	 Close	ROBOTC
•	 Open	ROBOTC
•	 Retry	downloading	the	program

9.	Restart	the	computer.
•	 Restart	your	computer
•	 Open	ROBOTC
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	program
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10.	Additional	Steps
•	 Try	using	the	same	program	on	another	computer,	with	the	same	Cortex.
•	 Try	using	the	same	program	on	the	same	computer,	with	a	different	Cortex.
•	 Try	using	a	different	USB	A-to-A	cable.

Problem:  Not able to Download ROBOTC Firmware over USB
1.	Was	the	correct	startup	sequence	followed	when	connecting	the	Cortex	to	the	computer?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	ROBOTC	Firmware

2.		Has	the	Master	CPU	Firmware	been	successfully	downloaded?
•	 Download	the	Master	CPU	Firmware .........................
•	 Retry	downloading	the	ROBOTC	Firmware

3.	Is	the	correct	Platform	Type	Selected?
•	 Verify	that	the	correct	platform	type	is	selected	under	Robot	>	Platform	Type
•	 Retry	downloading	the	ROBOTC	Firmware

4.	Is	the	connected	battery	sufficiently	charged?
•	 Swap	in	a	fully	charged	battery
•	 Retry	downloading	the	ROBOTC	Firmware

5.	Does	the	Cortex	need	to	be	power	cycled?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	ROBOTC	Firmware

6.	Try	another	USB	port	on	the	computer.
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	ROBOTC	Firmware

7. Restart ROBOTC.
•	 Close	ROBOTC
•	 Open	ROBOTC
•	 Retry	downloading	the	ROBOTC	Firmware

8.	Restart	the	computer.
•	 Restart	your	computer
•	 Open	ROBOTC
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	ROBOTC	Firmware
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9.	Additional	Steps
•	 Try	downloading	the	ROBOTC	Firmware	using	another	computer,	with	the	same	Cortex.
•	 Try	downloading	the	ROBOTC	Firmware	using	the	same	computer,	with	a	different	Cortex.
•	 Try	using	a	different	USB	A-to-A	cable.

10.	Slow	down	the	firmware	download	by	inserting	delays.
•	 Go	to	Window	>	Menu	level	>	and	select	Super	User
•	 Go	to	View	>	Preferences	>	Detailed	Preferences...
•	 Go	to	the	VEX	Cortex	Tab
•	 -	The	box	next	to	“Delay	Between	HID	Write”	allows	you	to	specify	a	number	of	
	 		milliseconds	to	insert	as	delays.	
•	 Add	a	5	millisecond	delay
•	 Retry	downloading	the	ROBOTC	Firmware
•	 Continue	to	add	short	delays	up	until	100	milliseconds.	
•	 Retry	downloading	the	Master	CPU	firmware	until	success.

Problem:  Not able to Download Master CPU Firmware over USB
1.	Was	the	correct	startup	sequence	followed	when	connecting	the	Cortex	to	the	computer?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	Master	CPU	Firmware

2.	Is	the	correct	Platform	Type	Selected?
•	 Verify	that	the	correct	platform	type	is	selected	under	Robot	>	Platform	Type
•	 Retry	downloading	the	Master	CPU	Firmware

3.	Is	the	connected	battery	sufficiently	charged?
•	 Swap	in	a	fully	charged	battery
•	 Retry	downloading	the	Master	CPU	Firmware

4.	Does	the	Cortex	need	to	be	power	cycled?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	Master	CPU	Firmware

5.	Try	another	USB	port	on	the	computer.
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	Master	CPU	Firmware

6. Restart ROBOTC.
•	 Close	ROBOTC
•	 Open	ROBOTC
•	 Retry	downloading	the	Master	CPU	Firmware

7.	Restart	the	computer.
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•	 Restart	your	computer
•	 Open	ROBOTC
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	Master	CPU	Firmware

8.	Additional	Steps
•	 Try	downloading	the	Master	CPU	Firmware	using	another	computer,	with	the	same	Cortex.
•	 Try	downloading	the	Master	CPU	Firmware	using	the	same	computer,	with	a	different	Cortex.
•	 Try	using	a	different	USB	A-to-A	cable.

9.	Slow	down	the	firmware	download	by	inserting	delays.
•	 Go	to	Window	>	Menu	level	>	and	select	Super	User
•	 Go	to	View	>	Preferences	>	Detailed	Preferences...
•	 Go	to	the	VEX	Cortex	Tab
•	 -	The	box	next	to	“Delay	Between	HID	Write”	allows	you	to	specify	a	number	of	
	 		milliseconds	to	insert	as	delays.	
•	 Add	a	5	millisecond	delay
•	 Retry	downloading	the	ROBOTC	Firmware
•	 Continue	to	add	short	delays	up	until	100	milliseconds.	
•	 Retry	downloading	the	Master	CPU	firmware	until	success.

10.	Try	the	download	using	the	VEXnet	Firmware	Upgrade	Utility,	supplied	by	VEX	Robotics.
•	 Download	the	VEXnet	Firmware	Upgrade	Ultility,	available	here:	
•	 http://www.vexforum.com/wiki/index.php/Software_Downloads
•	 Unzip	the	utility	and	instructions
•	 Follow	the	instructions	included	with	the	utility	to	update	the	firmware

Problem:  Program will not Compile
1.	If	you’re	using	Natural	Language	functions,	make	sure	you’re	in	the	Natural	Language	platform	type.
•	 Go	to	Robot	>	Platform	Type
•	 Select	the	Natural	Language	option
•	 Go	to	Robot	>	Compile	Program	to	recompile	your	code

2.	Is	the	correct	Platform	Type	Selected?
•	 Verify	that	the	correct	platform	type	is	selected	under	Robot	>	Platform	Type
•	 Retry	downloading	the	program

3.	Check	your	code	for	mistakes.
•	 Are	you	missing	any	curly	braces?
•	 Are	you	missing	any	semicolons?
•	 Are	any	of	your	commands	or	variables	improperly	capitalized?
•	 Do	any	of	your	commands	or	variables	contain	typos?
•	 Go	to	Robot	>	Compile	Program	to	recompile	your	code
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4.	Check	the	ROBOTC	Errors	window	for	hints.
•	 The	ROBOTC	Errors	window	(usually	located	at	the	bottom	of	the	screen)	will	display
•	 a	list	of	known	errors,	what	line	they’re	on,	and	some	information	about	the	error.	
•	 Double-click	errors	in	the	ROBOTC	Errors	window	to	highlight	the	affected	line	in	your	
•	 program.
•	 Correct	errors	(keep	in	mind	yellow	x’s	are	only	warnings,	and	white	x’s	are	only	information,	
•	 not	errors).
•	 Go	to	Robot	>	Compile	Program	to	recompile	your	code.

5.	Compare	your	code	to	programs	you	know	work	and	compile.
•	 Compare	your	code	t	similar	ROBOTC	Sample	Programs	(File	>	Open	Sample	Program)

Problem:		Program	compiles,	but	does	not	behave	as	desired
1.	Compare	your	code	to	programs	you	know	work	and	compile.
•	 Compare	your	code	t	similar	ROBOTC	Sample	Programs	(File	>	Open	Sample	Program)

2.	Think	“like	the	robot”.	The	robot	does	exactly	what	you	tell	it	to	do.	Nothing	more	and	nothing	less.	
•	 Is	there	an	important	step	you’re	forgetting	to	tell	the	robot?
•	 Go	back	to	your	pseudocode	plan.	Does	the	sequence	of	steps	make	sense	for	the	robot?

3.	Use	the	ROBOTC	Program	Debug	window	to	“Step”	through	your	code	line-by-line.
•	 Download	the	program	to	the	robot.
•	 When	the	Program	Debug	window	appears,	repeatedly	press	the	“Step”	button	to	run	the	program	line-by-
line.
•	 Observe	the	robot’s	behavior.	How	does	it	compare	to	the	desired	behavior?
•	 Try	to	identify	where	the	robot’s	behavior	differs	from	the	desired	behavior.

4.	Insert	visual	“flags”	in	your	program.
•	 Insert	optional	wait	statements	or	turn	on	different	LED’s	at	different	parts	of	the	program.
•	 When	the	robot	reaches	one	of	the	wait	statements	or	LED’s,	and	behaved	correctly,	you	know	that	the	
program	was	correct	up	until	that	point.
•	 Continue	to	insert	and	observe	these	optional	flags	until	you	identify	the	problem.

Problem:  Not able to open the ROBOTC Debugger
1.	Was	the	correct	startup	sequence	followed	when	connecting	the	Cortex	to	the	computer?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Retry	downloading	the	program	to	open	the	debugger

2.	Has	the	program	been	downloaded	to	the	Cortex?
•	 Download	the	program	to	open	the	debugger

3.	Have	the	Master	CPU	and	ROBOTC	Firmware	been	downloaded	successfully	to	the	Cortex?
•	 Do	they	need	to	be	re-downloaded?
•	 Download	the	Master	CPU	Firmware
•	 Download	the	ROBOTC	Firmware
•	 Power	Cycle	the	Cortex
•	 Retry	downloading	the	program	to	open	the	debugger
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4.	Check	the	VEX	Cortex	Download	Method.
•	 Verify	that	the	Robot	>	VEX	Cortex	Download	Method	is	set	to	“Download	using	VEXnet	or	USB”	or	
“Download	using	USB	Only”
•	 If	it	was	set	for	Competition:
o	 Download	the	program
o	 Turn		Cortex	OFF
o	 Disconnect	the	Cortex	from	the	computer
o	 Reconnect	the	Cortex	to	the	computer	over	USB
o Turn the Cortex On
o	 Retry	downloading	the	program	to	open	the	debugger

Problem:  Motors and/or Sensors Debug windows not functioning correctly
1.	Is	the	Cortex	turned	on	and	connected	to	a	charged	battery?
•	 Swap	in	a	fully	charged	battery
•	 Turn	the	Cortex	on
•	 Observe	the	debug	window	data

2.	Has	a	program	that	correctly	configures	the	sensors	been	downloaded	to	the	robot?
•	 Download	a	program	that	correctly	configures	the	sensors	on	the	robot.
•	 Run	the	program
•	 Stop	the	program
•	 Observe	the	sensor	data

3.	Is	the	Program	Debug	window	set	to	provide	“Continuous”	updates?
•	 Download	the	program	to	the	robot
•	 Under	the	“Refresh	Rate”	section,	verify	that	a	button	is	not	labeled	“Continuous”
•	 If	a	button	is	labeled	“Continuous”,	press	it	to	receive	continuous	updates
•	 Observe	the	sensor	data

4.	Have	the	Master	CPU	and	ROBOTC	Firmware	been	downloaded	successfully	to	the	Cortex?	
•	 Do	they	need	to	be	re-downloaded?
o	 Download	the	Master	CPU	Firmware .........................
o	 Download	the	ROBOTC	Firmware
o	 Power	Cycle	the	Cortex
o	 Re-download	the	program
o	 Observe	the	sensor	data

5.	Does	the	Cortex	need	to	be	power	cycled?
•	 Start	with	the	Cortex	Turned	OFF
•	 Connect	the	Cortex	to	the	computer	over	USB
•	 Turn	the	Cortex	On
•	 Re-download	the	program
•	 Observe	the	sensor	data

6. Restart ROBOTC.
•	 Close	ROBOTC
•	 Open	ROBOTC
•	 Re-download	the	program
•	 Observe	the	sensor	data
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Problem:  Program does not immediately run when Cortex is turned on
1.	Check	the	VEX	Cortex	Download	Method.
•	 Go	to	Robot	>	VEX	Cortex	Download	Method
•	 Select	“Download	using	USB	Only”	to	have	the	program	start	automatically
•	 Download	the	program
•	 Turn		Cortex	OFF
•	 Disconnect	the	Cortex	from	the	computer
•	 Turn	the	Cortex	On
•	 Program	should	start	automatically


